Leopard compatibility for Omni apps

by Linda Sharps on October 25, 2007

For those of you who may be haunting Apple's Leopard countdown page, counting each and every second until you can get your early-adopter mitts on the newest OS; watching the guided tour over and over and maybe considering expanding your wardrobe to include more long-sleeved black t-shirts; working on your subdued, yet expressive hand gestures; pondering the sex appeal of various reflective surfaces … for YOU, I have good news: Omni has updated nearly all of our software so that when you start running Leopard on Friday (at 6 PM exactly), your favorite Omni apps won't let you down.

Well, to be clear, I mean they'll run on Leopard, I can't guarantee they won't let you down in other ways (for instance: not calling after a first date, failing to put their dishes in the dishwasher, consistently adding possessive apostrophes to plural nouns, etc).

In a nutshell:

• Current final releases of OmniWeb and OmniDiskSweeper are Leopard-ready

• Current beta releases of OmniFocus, OmniGraffle, OmniOutliner, and OmniDazzle are Leopard-ready

• OmniPlan has some Leopard Issues that it's working through with talk therapy and an experimental drug regimen, but we hope to offer a 10.5 update in the next few weeks.

A full compatibility report is available on our Leopard status page, along with some fancy illustrative buttons.